Here are the plugins that come by default with Flood. If you want to use any of these, you don't need to do anything - simply use them in your test plan. If you'd like to use other plugins, this is still possible but you will need to upload the jar file with your script.

|-- bin
|   |-- ApacheJMeter.jar
--
|-- extras
|   `-- ant-jmeter-1.1.1.jar
|-- lib
|   |-- accessors-smart-1.2.jar
|   |-- asm-6.0.jar
|   |-- astyanax-1.56.25.jar
|   |-- bsf-2.4.0.jar
|   |-- bsh-2.0b6.jar
|   |-- bshclient.jar
|   |-- caffeine-2.6.1.jar
|   |-- cassandra-driver-core-1.0.0.jar
|   |-- cmdrunner-2.0.jar
|   |-- commons-beanutils-1.8.3.jar
|   |-- commons-codec-1.11.jar
|   |-- commons-collections-3.2.2.jar
|   |-- commons-configuration-1.6.jar
|   |-- commons-dbcp2-2.2.0.jar
|   |-- commons-io-2.6.jar
|   |-- commons-jexl-2.1.1.jar
|   |-- commons-jexl3-3.1.jar
|   |-- commons-lang-2.6.jar
|   |-- commons-lang3-3.7.jar
|   |-- commons-math3-3.6.1.jar
|   |-- commons-net-3.6.jar
|   |-- commons-pool-1.6.jar
|   |-- commons-pool2-2.5.0.jar
|   |-- darcula.jar
|   |-- dec-0.1.2.jar
|   |-- dnsjava-2.1.8.jar
|   |-- ext
|   |   |-- ApacheJMeter_components.jar
|   |   |-- ApacheJMeter_core.jar
|   |   |-- ApacheJMeter_ftp.jar
|   |   |-- ApacheJMeter_functions.jar
|   |   |-- ApacheJMeter_http.jar
|   |   |-- ApacheJMeter_java.jar
|   |   |-- ApacheJMeter_jdbc.jar
|   |   |-- ApacheJMeter_jms.jar
|   |   |-- ApacheJMeter_junit.jar
|   |   |-- ApacheJMeter_ldap.jar
|   |   |-- ApacheJMeter_mail.jar
|   |   |-- ApacheJMeter_mongodb.jar
|   |   |-- ApacheJMeter_native.jar
|   |   |-- ApacheJMeter_ssh-1.1.1-SNAPSHOT.jar
|   |   |-- ApacheJMeter_tcp.jar
|   |   |-- CassJMeter-0.2-SNAPSHOT.jar
|   |   |-- CustomSoapSampler-1.3.jar
|   |   |-- JMeterWebSocketSampler-1.0.2-SNAPSHOT.jar
|   |   |-- ant-1.9.4.jar
|   |   |-- ant-antlr-1.9.4.jar
|   |   |-- ant-junit-1.9.4.jar
|   |   |-- ant-launcher-1.9.4.jar
|   |   |-- bsf-2.4.0.jar
|   |   |-- commons-cli-1.2.jar
|   |   |-- commons-logging-1.2.jar
|   |   |-- flood-jmeter-4.0.jar
|   |   |-- gpars-1.2.1.jar
|   |   |-- groovy-2.4.1.jar
|   |   |-- groovy-ant-2.4.1.jar
|   |   |-- groovy-bsf-2.4.1.jar
|   |   |-- groovy-console-2.4.1.jar
|   |   |-- groovy-docgenerator-2.4.1.jar
|   |   |-- groovy-groovydoc-2.4.1.jar
|   |   |-- groovy-groovysh-2.4.1.jar
|   |   |-- groovy-jmx-2.4.1.jar
|   |   |-- groovy-json-2.4.1.jar
|   |   |-- groovy-jsr223-2.4.1.jar
|   |   |-- groovy-nio-2.4.1.jar
|   |   |-- groovy-servlet-2.4.1.jar
|   |   |-- groovy-sql-2.4.1.jar
|   |   |-- groovy-swing-2.4.1.jar
|   |   |-- groovy-templates-2.4.1.jar
|   |   |-- groovy-test-2.4.1.jar
|   |   |-- groovy-testng-2.4.1.jar
|   |   |-- groovy-xml-2.4.1.jar
|   |   |-- hamcrest-core-1.3.jar
|   |   |-- ivy-2.4.0.jar
|   |   |-- jansi-1.11.jar
|   |   |-- jcommander-1.47.jar
|   |   |-- jline-2.12.jar
|   |   |-- jmeter-bzm-http2-1.1.jar
|   |   |-- jmeter-hls-1.2.jar
|   |   |-- jmeter-parallel-0.4.jar
|   |   |-- jmeter-plugins-autostop-0.1.jar
|   |   |-- jmeter-plugins-casutg-2.5.jar
|   |   |-- jmeter-plugins-cmd-2.1.jar
|   |   |-- jmeter-plugins-csl-0.1.jar
|   |   |-- jmeter-plugins-csvars-0.1.jar
|   |   |-- jmeter-plugins-dbmon-0.1.jar
|   |   |-- jmeter-plugins-directory-listing-0.2.jar
|   |   |-- jmeter-plugins-dummy-0.2.jar
|   |   |-- jmeter-plugins-ffw-2.0.jar
|   |   |-- jmeter-plugins-fifo-0.2.jar
|   |   |-- jmeter-plugins-filterresults-2.1.jar
|   |   |-- jmeter-plugins-functions-2.0.jar
|   |   |-- jmeter-plugins-graphs-additional-2.0.jar
|   |   |-- jmeter-plugins-graphs-basic-2.0.jar
|   |   |-- jmeter-plugins-graphs-composite-2.0.jar
|   |   |-- jmeter-plugins-graphs-dist-2.0.jar
|   |   |-- jmeter-plugins-graphs-ggl-2.0.jar
|   |   |-- jmeter-plugins-graphs-vs-2.0.jar
|   |   |-- jmeter-plugins-hadoop-2.0.jar
|   |   |-- jmeter-plugins-httpraw-0.1.jar
|   |   |-- jmeter-plugins-jms-0.2.jar
|   |   |-- jmeter-plugins-jmxmon-0.2.jar
|   |   |-- jmeter-plugins-json-2.6.jar
|   |   |-- jmeter-plugins-lockfile-0.1.jar
|   |   |-- jmeter-plugins-manager-0.19.jar
|   |   |-- jmeter-plugins-mergeresults-2.1.jar
|   |   |-- jmeter-plugins-oauth-0.1.jar
|   |   |-- jmeter-plugins-pde-0.1.jar
|   |   |-- jmeter-plugins-perfmon-2.1.jar
|   |   |-- jmeter-plugins-plancheck-2.2.jar
|   |   |-- jmeter-plugins-prmctl-0.3.jar
|   |   |-- jmeter-plugins-random-csv-data-set-0.6.jar
|   |   |-- jmeter-plugins-redis-0.2.jar
|   |   |-- jmeter-plugins-rotating-listener-0.2.jar
|   |   |-- jmeter-plugins-synthesis-2.1.jar
|   |   |-- jmeter-plugins-table-server-2.3.jar
|   |   |-- jmeter-plugins-tst-2.2.jar
|   |   |-- jmeter-plugins-udp-0.3.jar
|   |   |-- jmeter-plugins-wsc-0.3.jar
|   |   |-- jmeter-plugins-xml-0.1.jar
|   |   |-- jmeter-plugins-xmpp-1.5.1.jar
|   |   |-- jmeter-sshmon-1.0.jar
|   |   |-- jmeter-websocket-samplers-1.1.jar
|   |   |-- jmeter-wssecurity-1.5.jar
|   |   |-- jmeter.backendlistener.elasticsearch-2.2.2.jar
|   |   |-- json-1.8.jar
|   |   |-- json-path-2.4.0.jar
|   |   |-- json-simple-1.1.1.jar
|   |   |-- json-smart-2.3.jar
|   |   |-- jsp-api-2.0.jar
|   |   |-- jsr166y-1.7.0.jar
|   |   |-- junit-4.12.jar
|   |   |-- kafkameter-0.2.0.jar
|   |   |-- mqtt-jmeter-0.0.1-SNAPSHOT.jar
|   |   |-- multiverse-core-0.7.0.jar
|   |   |-- mysql-connector-java-5.1.34-bin.jar
|   |   |-- mysql-connector-java-5.1.45-bin.jar
|   |   |-- openbeans-1.0.jar
|   |   |-- postgresql-42.1.4.jar
|   |   |-- qdox-1.12.1.jar
|   |   |-- servlet-api-2.4.jar
--
|   |   |   |-- lib
|   |   |   |   |-- c3p0-0.9.1-pre6.jar
|   |   |   |   |-- jboss-common-jdbc-wrapper-src.jar
|   |   |   |   |-- jboss-common-jdbc-wrapper.jar
|   |   |   |   `-- slf4j-api-1.6.1.jar
--
|   |   |       `-- ssl-test-certs
|   |   |-- testng-6.8.13.jar
|   |   |-- xmlpull-1.1.3.1.jar
|   |   `-- xstream-1.4.7.jar
|   |-- freemarker-2.3.23.jar
|   |-- geronimo-jms_1.1_spec-1.1.1.jar
|   |-- groovy-all-2.4.13.jar
|   |-- gson-2.2.4.jar
|   |-- guava-19.0.0.jar
|   |-- hadoop-core-1.1.2.jar
|   |-- hamcrest-core-1.3.jar
|   |-- hamcrest-date-2.0.4.jar
|   |-- hbase-0.94.5.jar
|   |-- hector-core-1.1-2.jar
|   |-- http2-client-9.4.0.v20161208.jar
|   |-- http2-common-9.4.0.v20161208.jar
|   |-- http2-hpack-9.4.0.v20161208.jar
|   |-- httpasyncclient-4.1.3.jar
|   |-- httpclient-4.5.5.jar
|   |-- httpcore-4.4.9.jar
|   |-- httpcore-nio-4.4.9.jar
|   |-- httpmime-4.5.5.jar
|   |-- jackson-core-asl-1.8.8.jar
|   |-- jackson-mapper-asl-1.8.8.jar
|   |-- jbosh-0.8.0.jar
|   |-- jcharts-0.7.5.jar
|   |-- jcl-over-slf4j-1.7.25.jar
|   |-- jedis-2.2.1.jar
|   |-- jetty-alpn-client-9.4.0.v20161208.jar
|   |-- jetty-client-9.4.0.v20161208.jar
|   |-- jetty-http-9.1.1.v20140108.jar
|   |-- jetty-io-9.1.1.v20140108.jar
|   |-- jetty-osgi-alpn-9.4.0.v20161208.jar
|   |-- jetty-util-9.1.1.v20140108.jar
|   |-- jmeter-plugins-cmn-jmeter-0.5.jar
|   |-- jmeter-plugins-common-io-0.2.jar
|   |-- jodd-core-4.1.4.jar
|   |-- jodd-lagarto-4.1.4.jar
|   |-- jodd-log-4.1.4.jar
|   |-- jodd-props-4.1.4.jar
|   |-- jorphan.jar
|   |-- jsch-0.1.50.jar
|   |-- json-lib-2.4-jdk15.jar
|   |-- json-path-2.4.0.jar
|   |-- json-smart-2.3.jar
|   |-- jsoup-1.11.2.jar
|   |-- jtidy-r938.jar
|   |-- junit
|   |   `-- test.jar
|   |-- junit-4.12.jar
|   |-- kafka_2.8.2-0.8.0.jar
|   |-- log4j-1.2-api-2.10.0.jar
|   |-- log4j-api-2.10.0.jar
|   |-- log4j-core-2.10.0.jar
|   |-- log4j-slf4j-impl-2.10.0.jar
|   |-- mail-1.5.0-b01.jar
|   |-- metrics-core-2.2.0.jar
|   |-- mongo-java-driver-2.11.3.jar
|   |-- mqtt-websocket-java-1.0.1.jar
|   |-- org.eclipse.paho.client.mqttv3-1.0.2.jar
|   |-- oro-2.0.8.jar
|   |-- perfmon-2.2.2.jar
|   |-- ph-commons-9.0.0.jar
|   |-- ph-css-6.0.0.jar
|   |-- qpid-client-0.20.jar
|   |-- qpid-common-0.20.jar
|   |-- rhino-1.7.7.2.jar
|   |-- rsyntaxtextarea-2.6.1.jar
|   |-- scala-library-2.8.2.jar
|   |-- serializer-2.7.2.jar
|   |-- servo-core-0.4.32.jar
|   |-- slf4j-api-1.7.25.jar
|   |-- slf4j-ext-1.7.25.jar
|   |-- smack-bosh-4.0.7.jar
|   |-- smack-core-4.0.7.jar
|   |-- smack-extensions-4.0.7.jar
|   |-- smack-tcp-4.0.7.jar
|   |-- spring-core-2.5.6.jar
|   |-- spring-jms-2.5.6.jar
|   |-- tika-core-1.17.jar
|   |-- tika-parsers-1.17.jar
|   |-- websocket-api-9.1.1.v20140108.jar
|   |-- websocket-client-9.1.1.v20140108.jar
|   |-- websocket-common-9.1.1.v20140108.jar
|   |-- wss4j-ws-security-common-2.1.8.jar
|   |-- wss4j-ws-security-dom-2.1.8.jar
|   |-- xalan-2.7.2.jar
|   |-- xercesImpl-2.11.0.jar
|   |-- xml-apis-1.4.01.jar
|   |-- xmlgraphics-commons-2.2.jar
|   |-- xmlpull-1.1.3.1.jar
|   |-- xmlsec-2.0.8.jar
|   |-- xom-1.2.10.jar
|   |-- xpp3_min-1.1.4c.jar
|   |-- xstream-1.4.10.jar
|   `-- zookeeper-3.4.5.jar

As always, let us know if you have any questions!

Did this answer your question?