We currently support a stable version of JMeter 3.3 r1808647 with the following plugin / jar versions:

|-- bin
|   |-- ApacheJMeter.jar
--
|-- extras
|   `-- ant-jmeter-1.1.1.jar
|-- lib
|   |-- accessors-smart-1.2.jar
|   |-- asm-5.2.jar
|   |-- bsf-2.4.0.jar
|   |-- bsh-2.0b5.jar
|   |-- bshclient.jar
|   |-- caffeine-2.5.5.jar
|   |-- cmdrunner-2.0.jar
|   |-- commons-codec-1.10.jar
|   |-- commons-collections-3.2.2.jar
|   |-- commons-dbcp2-2.1.1.jar
|   |-- commons-io-2.5.jar
|   |-- commons-jexl-2.1.1.jar
|   |-- commons-jexl3-3.1.jar
|   |-- commons-lang3-3.6.jar
|   |-- commons-math3-3.6.1.jar
|   |-- commons-net-3.6.jar
|   |-- commons-pool2-2.4.2.jar
|   |-- dec-0.1.2.jar
|   |-- dnsjava-2.1.8.jar
|   |-- ext
|   |   |-- ApacheJMeter_components.jar
|   |   |-- ApacheJMeter_core.jar
|   |   |-- ApacheJMeter_ftp.jar
|   |   |-- ApacheJMeter_functions.jar
|   |   |-- ApacheJMeter_http.jar
|   |   |-- ApacheJMeter_java.jar
|   |   |-- ApacheJMeter_jdbc.jar
|   |   |-- ApacheJMeter_jms.jar
|   |   |-- ApacheJMeter_junit.jar
|   |   |-- ApacheJMeter_ldap.jar
|   |   |-- ApacheJMeter_mail.jar
|   |   |-- ApacheJMeter_mongodb.jar
|   |   |-- ApacheJMeter_native.jar
|   |   |-- ApacheJMeter_tcp.jar
|   |   |-- JMeterWebSocketSampler-1.0.2-SNAPSHOT.jar
|   |   |-- ant-1.9.4.jar
|   |   |-- ant-antlr-1.9.4.jar
|   |   |-- ant-junit-1.9.4.jar
|   |   |-- ant-launcher-1.9.4.jar
|   |   |-- bsf-2.4.0.jar
|   |   |-- commons-cli-1.2.jar
|   |   |-- commons-logging-1.2.jar
|   |   |-- flood-jmeter-3.3.jar
|   |   |-- gpars-1.2.1.jar
|   |   |-- groovy-2.4.1.jar
|   |   |-- groovy-ant-2.4.1.jar
|   |   |-- groovy-bsf-2.4.1.jar
|   |   |-- groovy-console-2.4.1.jar
|   |   |-- groovy-docgenerator-2.4.1.jar
|   |   |-- groovy-groovydoc-2.4.1.jar
|   |   |-- groovy-groovysh-2.4.1.jar
|   |   |-- groovy-jmx-2.4.1.jar
|   |   |-- groovy-json-2.4.1.jar
|   |   |-- groovy-jsr223-2.4.1.jar
|   |   |-- groovy-nio-2.4.1.jar
|   |   |-- groovy-servlet-2.4.1.jar
|   |   |-- groovy-sql-2.4.1.jar
|   |   |-- groovy-swing-2.4.1.jar
|   |   |-- groovy-templates-2.4.1.jar
|   |   |-- groovy-test-2.4.1.jar
|   |   |-- groovy-testng-2.4.1.jar
|   |   |-- groovy-xml-2.4.1.jar
|   |   |-- hamcrest-core-1.3.jar
|   |   |-- ivy-2.4.0.jar
|   |   |-- jansi-1.11.jar
|   |   |-- jcommander-1.47.jar
|   |   |-- jline-2.12.jar
|   |   |-- jmeter-plugins-autostop-0.1.jar
|   |   |-- jmeter-plugins-casutg-2.4.jar
|   |   |-- jmeter-plugins-dummy-0.2.jar
|   |   |-- jmeter-plugins-ffw-2.0.jar
|   |   |-- jmeter-plugins-fifo-0.2.jar
|   |   |-- jmeter-plugins-functions-2.0.jar
|   |   |-- jmeter-plugins-jms-0.2.jar
|   |   |-- jmeter-plugins-manager-0.16.jar
|   |   |-- jmeter-plugins-prmctl-0.3.jar
|   |   |-- jmeter-plugins-random-csv-data-set-0.1.jar
|   |   |-- jmeter-plugins-tst-2.1.jar
|   |   |-- json-1.8.jar
|   |   |-- json-path-2.4.0.jar
|   |   |-- json-simple-1.1.1.jar
|   |   |-- json-smart-2.3.jar
|   |   |-- jsp-api-2.0.jar
|   |   |-- jsr166y-1.7.0.jar
|   |   |-- junit-4.12.jar
|   |   |-- multiverse-core-0.7.0.jar
|   |   |-- mysql-connector-java-5.1.34-bin.jar
|   |   |-- openbeans-1.0.jar
|   |   |-- qdox-1.12.1.jar
|   |   |-- servlet-api-2.4.jar
|   |   |-- testng-6.8.13.jar
|   |   |-- xmlpull-1.1.3.1.jar
|   |   `-- xstream-1.4.7.jar
|   |-- freemarker-2.3.23.jar
|   |-- geronimo-jms_1.1_spec-1.1.1.jar
|   |-- groovy-all-2.4.12.jar
|   |-- hamcrest-core-1.3.jar
|   |-- hamcrest-date-2.0.4.jar
|   |-- httpasyncclient-4.1.3.jar
|   |-- httpclient-4.5.3.jar
|   |-- httpcore-4.4.7.jar
|   |-- httpcore-nio-4.4.7.jar
|   |-- httpmime-4.5.3.jar
|   |-- jcharts-0.7.5.jar
|   |-- jcl-over-slf4j-1.7.25.jar
|   |-- jetty-http-9.1.1.v20140108.jar
|   |-- jetty-io-9.1.1.v20140108.jar
|   |-- jetty-util-9.1.1.v20140108.jar
|   |-- jmeter-plugins-cmn-jmeter-0.4.jar
|   |-- jodd-core-3.8.6.jar
|   |-- jodd-lagarto-3.8.6.jar
|   |-- jodd-log-3.8.6.jar
|   |-- jodd-props-3.8.6.jar
|   |-- jorphan.jar
|   |-- json-path-2.4.0.jar
|   |-- json-smart-2.3.jar
|   |-- jsoup-1.10.3.jar
|   |-- jtidy-r938.jar
|   |-- junit
|   |   `-- test.jar
|   |-- junit-4.12.jar
|   |-- log4j-1.2-api-2.8.2.jar
|   |-- log4j-api-2.8.2.jar
|   |-- log4j-core-2.8.2.jar
|   |-- log4j-slf4j-impl-2.8.2.jar
|   |-- mail-1.5.0-b01.jar
|   |-- mongo-java-driver-2.11.3.jar
|   |-- oro-2.0.8.jar
|   |-- ph-commons-8.6.6.jar
|   |-- ph-css-5.0.4.jar
|   |-- qpid-client-0.20.jar
|   |-- qpid-common-0.20.jar
|   |-- rhino-1.7.7.1.jar
|   |-- rsyntaxtextarea-2.6.1.jar
|   |-- serializer-2.7.2.jar
|   |-- slf4j-api-1.7.25.jar
|   |-- slf4j-ext-1.7.25.jar
|   |-- spring-core-2.5.6.jar
|   |-- spring-jms-2.5.6.jar
|   |-- tika-core-1.16.jar
|   |-- tika-parsers-1.16.jar
|   |-- websocket-api-9.1.1.v20140108.jar
|   |-- websocket-client-9.1.1.v20140108.jar
|   |-- websocket-common-9.1.1.v20140108.jar
|   |-- xalan-2.7.2.jar
|   |-- xercesImpl-2.11.0.jar
|   |-- xml-apis-1.4.01.jar
|   |-- xmlgraphics-commons-2.2.jar
|   |-- xmlpull-1.1.3.1.jar
|   |-- xpp3_min-1.1.4c.jar
|   `-- xstream-1.4.10.jar

Did this answer your question?